Contact

Call

Call us

Our support team is happy to help you, be it for technical or administrative issues. We’re there for you!

 

+41 (0)84 800 80 80

(Calls from Switzerland 8 centimes / minute)

 

Monday to Friday/Saturday1
9:00 am – 12:00 pm & 1:30 – 5:00 pm

1 Administration: Monday to Friday, technical support: Monday to Saturday

Write

Write to us

To be able to help you as quickly and effectively as possible, we kindly ask that you make your request as specific as possible. And of course you can contact us by email: support@hoststar.com

Is your website ready for PHP 7?

Support > Hosting > PHP settings

PHP 5.6 will only be supported on our servers until December 2020. After that the default version of the PHP settings will automatically be changed to PHP 7.1 (you can change) this at any time.

PHP 7 is a new major version. Basically nothing should stand in the way of a problem-free migration from PHP 5.6 to 7.1, but we recommend that you clarify the following points in advance:

1. Incompatible functionalities

Due to some remote functionalities in PHP 7.1, existing codes have to be tested with the new version to be on the safe side and code adjustments have to be made. The most important changes are:

  • The indirect access to variables, properties and methods will be evaluated more strictly:
    PHP 5 - up to now ${$foo['bar']['baz']}
    PHP 7 - new ($$foo)['bar']['baz'] )

     
  • As of PHP 7.1, ext/mysql is no longer supported. Therefore it would be necessary to adapt to ext/pdo_mysql or ext/mysqli. With the tool «MySQL wrapper for MySQLi» this adjustment is simplified for you!
     

All the uncompatible functionalities that apply to the versions of PHP 7 are listed in detail on the official PHP website under «Migrating from PHP 5.6 to PHP 7».

The phan und phpstan tools will help you check your code for compatibility with PHP 7.1.

 

2. CMS Installations

The most commonly used CMS (Content-Management-Systems) in the current versions are all compatible with PHP 7, as follows:

Contao Version 3.5.5 or higher
Drupal Drupal 7 as well as Drupal 8
Joomla Version 3.5
Version 3.7 or higher compatible with PHP 7.1
Typo 3 Version 7 LTS and higher
WordPress Version 4.4 or higher
WP Plugins & Themes Checking with the Plugin «PHP Compatibility Checker»
Was this article helpful?